<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width,initial-scale=1.0,maximum-scale=1" />
        <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="http://littlevillagemag.com/xmlrpc.php">
        <link rel="shortcut icon" href="http://littlevillagemag.com/wp-content/uploads/2017/05/favicon-plain.png">
    <link rel="apple-touch-icon" href="http://littlevillagemag.com/wp-content/uploads/2017/05/ap-1.png">
    <link rel="apple-touch-icon" sizes="72x72" href="">
    <link rel="apple-touch-icon" sizes="114x114" href="http://littlevillagemag.com/wp-content/uploads/2017/05/ap-2.png">
    <link rel="apple-touch-icon" sizes="149x149" href="">
        <title>This week in political activism: June 5 &#8211; 11 &#8211; Little Village</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Little Village &raquo; Feed" href="http://littlevillagemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Little Village &raquo; Comments Feed" href="http://littlevillagemag.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Little Village &raquo; This week in political activism: June 5 &#8211; 11 Comments Feed" href="http://littlevillagemag.com/this-week-in-political-activism-june-5-11/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/littlevillagemag.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='hcode-animate-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/animate.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-bootstrap-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-et-line-icons-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/et-line-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-font-awesome-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-magnific-popup-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/magnific-popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-owl-carousel-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-owl-transitions-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/owl.transitions.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-full-slider-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/full-slider.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-text-effect-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/text-effect.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-responsive-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='hcode-extralayers-style-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/extralayers.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='hcode-ie-css'  href='http://littlevillagemag.com/wp-content/themes/h-code/assets/css/style-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='hcode-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A100%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Cvietnamese' type='text/css' media='all' />
<script type='text/javascript' src='http://littlevillagemag.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/this-week-in-political-activism-june-5-11\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"http:\/\/littlevillagemag.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='//littlevillagemag.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/plugins/js_composer/assets/js/vendors/woocommerce-add-to-cart.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/html5shiv.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://littlevillagemag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://littlevillagemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://littlevillagemag.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Complaint resolved against Iowa City&#8217;s Rev. Anna Blaedel for performing same-sex wedding' href='http://littlevillagemag.com/complaint-resolved-against-iowa-citys-rev-anna-blaedel-for-performing-same-sex-wedding/' />
<meta name="generator" content="WordPress 4.7.5" />
<meta name="generator" content="WooCommerce 2.6.14" />
<link rel="canonical" href="http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" />
<link rel='shortlink' href='http://littlevillagemag.com/?p=118309' />
<link rel="alternate" type="application/json+oembed" href="http://littlevillagemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flittlevillagemag.com%2Fthis-week-in-political-activism-june-5-11%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://littlevillagemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flittlevillagemag.com%2Fthis-week-in-political-activism-june-5-11%2F&#038;format=xml" />
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://littlevillagemag.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><style type="text/css" title="dynamic-css" class="options-output">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</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>            <style>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</style>
    
        <style>
@import url('https://fonts.googleapis.com/css?family=Noto+Serif:400,400i,700,700i');
</style>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
  
  // Here, we have to define size mapping for each of the ad unit.
  
var bannermapping = googletag.sizeMapping().
addSize([769, 0], [728, 250]).
addSize([0, 0], [300, 250]).
build();

var recmapping1 = googletag.sizeMapping().
addSize([0, 0], [300, 250]).
build();

var recmapping2 = googletag.sizeMapping().
addSize([0, 0], [300, 250]).
build();

var recmapping3 = googletag.sizeMapping().
addSize([0, 0], [300, 250]).
build();

var recmapping4 = googletag.sizeMapping().
addSize([0, 0], [300, 250]).
build();
  
  
    googletag.defineSlot('/16322013/300x250_1', [300, 250], 'div-gpt-ad-1488236908701-0').defineSizeMapping(recmapping1).addService(googletag.pubads());
    googletag.defineSlot('/16322013/300x250_2', [300, 250], 'div-gpt-ad-1488236908701-1').defineSizeMapping(recmapping2).addService(googletag.pubads());
    googletag.defineSlot('/16322013/300x250_3', [300, 250], 'div-gpt-ad-1488236908701-2').defineSizeMapping(recmapping3).addService(googletag.pubads());
    googletag.defineSlot('/16322013/300x250_4', [300, 250], 'div-gpt-ad-1488236908701-3').defineSizeMapping(recmapping4).addService(googletag.pubads());
    googletag.defineSlot('/16322013/728x250', [[300, 250], [728, 250]], 'div-gpt-ad-1488236908701-4').defineSizeMapping(bannermapping).addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-18614304-1', 'auto');
  ga('send', 'pageview');

</script>

</head>
<body class="post-template-default single single-post postid-118309 single-format-standard wpb-js-composer js-comp-ver-5.0.1 vc_responsive">




<div class="leader-ad-container">
<p class="leader-ad-disclaimer">Advertisement</p>
<div class="leader-ad">

<!-- /16322013/728x250 -->
<div id='div-gpt-ad-1488236908701-4'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1488236908701-4'); });
</script>
</div>

</div>
</div>



    <header>    
        <div class="top-header-area">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <!-- sidebar --><div id="text-38" class="widget widget_text">			<div class="textwidget"><div id="getapp"><a href="http://littlevillagemag.saambaa.com/apps/iowa-city.html" target="_blank"><h2 style="font-size:47px; line-height:52px; letter-spacing:-1px; font-family: 'Oswald', arial, sans-serif; background-color:#8dc975; color:#fff; padding:8px; padding-top:5px; padding-bottom:5px;">Get the LV<br />
<span style="color:#f1f1f1;">Events App</span></h2></a></div></div>
		</div><!-- end sidebar --><!-- sidebar --><div id="text-40" class="widget widget_text">			<div class="textwidget"><h2 style="margin-top:-6px; padding-left:8px; font-size:54px; line-height:60px; letter-spacing:-2px; font-family: 'Oswald', arial, sans-serif;">Subscribe<br />
to the</br />
<span style="color:#888;">Weekender</span></h2>

<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-081711.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:270px;}
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="http://littlevillagemag.us7.list-manage1.com/subscribe/post?u=5d8011b99892e01fc9f7ad17c&amp;id=4e3b14ed3a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
	
	<input style="width:99%;" type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
	<div class="clear"><input style="width:99%;" type="submit" value="SUBSCRIBE" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</form>
</div>

<!--End mc_embed_signup--></div>
		</div><!-- end sidebar --><!-- sidebar --><div id="text-35" class="widget widget_text">			<div class="textwidget"><!-- lv_sidebar_square -->
<div id='div-gpt-ad-1380611800338-3' style='width:270px; height:270px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1380611800338-3'); });
</script>
</div>
<span style="font-size:11px; color:#999;">Advertisement</span></div>
		</div><!-- end sidebar -->		<!-- sidebar --><div id="recent-posts-2" class="widget widget_recent_entries">		<!-- headline --><h5 class="widget-title">The latest&#8230;</h5>		<ul>
					<li>
				<a href="http://littlevillagemag.com/this-week-in-political-activism-june-5-11/">This week in political activism: June 5 &#8211; 11</a>
							<span class="post-date">Jun 5, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/complaint-resolved-against-iowa-citys-rev-anna-blaedel-for-performing-same-sex-wedding/">Complaint resolved against Iowa City&#8217;s Rev. Anna Blaedel for performing same-sex wedding</a>
							<span class="post-date">Jun 5, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/arts-fest-2017-beats-the-heat-with-a-jam-packed-weekend/">Arts Fest 2017 beats the heat with a jam-packed weekend</a>
							<span class="post-date">Jun 5, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/kim-weaver-cites-personal-safety-concerns-as-she-drops-bid-against-steve-king/">Kim Weaver cites personal safety concerns as she drops bid against Steve King</a>
							<span class="post-date">Jun 5, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/interview-a-chat-with-tim-kasher-ahead-of-his-stop-at-the-mill-as-he-tours-with-the-first-album-on-his-new-label/">Interview: A chat with Tim Kasher ahead of his stop at The Mill as he tours with the first album on his new label</a>
							<span class="post-date">Jun 4, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/mamis-authentic-owners-to-close-iowa-city-location-open-new-restaurant-on-burlington-street/">Mami&#8217;s Authentic owners to close Iowa City location, open new restaurant on Burlington Street</a>
							<span class="post-date">Jun 2, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/iowa-citys-fuji-steakhouse-location-for-sale/">Iowa City&#8217;s Fuji Steakhouse location for sale</a>
							<span class="post-date">Jun 2, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/democracy-in-crisis-podcast-hannah-arendt-in-the-age-of-trump/">Democracy in Crisis Podcast: Hannah Arendt in the Age of Trump</a>
							<span class="post-date">Jun 2, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/graffiti-inspired-exhibition-wasteland-2-features-the-post-apocalyptic-at-radinc/">Graffiti-inspired exhibition, &#8216;Wastedland 2,&#8217; features the post-apocalyptic at RADinc.</a>
							<span class="post-date">Jun 2, 2017</span>
						</li>
					<li>
				<a href="http://littlevillagemag.com/hijinks-ensue-in-revival-theatre-companys-beautiful-production-of-victorvictoria/">Hijinks ensue in Revival Theatre Company&#8217;s beautiful production of &#8216;Victor/Victoria&#8217;</a>
							<span class="post-date">Jun 1, 2017</span>
						</li>
				</ul>
		</div><!-- end sidebar -->		                    </div>
                </div>
            </div>
        </div>

    <nav class="navbar navbar-default navbar-fixed-top nav-transparent overlay-nav sticky-nav nav-dark  nav-white ">
        <div class="container">
            <div class="row">
                <!-- logo -->
                <div class="col-md-2 pull-left">
                                                                <a class="logo-light" href="http://littlevillagemag.com">
                                                                    <img alt="" src="http://littlevillagemag.com/wp-content/uploads/2017/02/LV5_Header_logo_169_48_grey.png" class="logo" />
                                                                    <img alt="" src="http://littlevillagemag.com/wp-content/uploads/2017/02/LV5_header_logo_Retina_grey.png" class="retina-logo" style="width:169px; max-height:48px" />
                                                                </a>
                                                                    <a class="logo-dark" href="http://littlevillagemag.com">
                                                                    <img alt="" src="http://littlevillagemag.com/wp-content/uploads/2017/02/LV5_Header_logo_169_48_grey.png" class="logo" />
                                                                    <img alt="" src="http://littlevillagemag.com/wp-content/uploads/2017/02/LV5_header_logo_Retina_grey.png" class="retina-logo-light" style="width:169px; max-height:48px"/>
                                                            </a>
                                        </div>
                <!-- end logo -->
                <!-- search and cart  -->
                                                            <div class="col-md-2 no-padding-left search-cart-header pull-right">
                                                                    <div id="top-search">
                            <!-- nav search -->
                            <a href="#search-header" class="header-search-form"><i class="fa fa-search search-button"></i></a>
                            <!-- end nav search -->
                        </div>
                        <!-- search input-->
                        <form id="search-header" method="get" action="http://littlevillagemag.com/" name="search-header" class="mfp-hide search-form-result">
                            <div class="search-form position-relative">
                                <button type="submit" class="fa fa-search close-search search-button black-text"></button>
                                <input type="text" name="s" class="search-input" value="" placeholder="Browse the Little Village archive..." autocomplete="off">
                            </div>
                        </form>
                        <!-- end search input -->

                        
                                            </div>
                            <!-- end search and cart  -->
                <!-- toggle navigation -->
                <div class="navbar-header col-sm-8 col-xs-2 pull-right">
                    <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-collapse">
                        <span class="sr-only">Toggle navigation</span>
                        <span class="icon-bar"></span>
                        <span class="icon-bar"></span>
                        <span class="icon-bar"></span>
                    </button>
                </div>
                <!-- toggle navigation end -->
                <!-- main menu -->
                                                            <div class="col-md-8 no-padding-right accordion-menu text-right">
                                    <div id="mega-menu" class="navbar-collapse collapse"><ul id="menu-lv5-header-final" class="mega-menu-ul nav navbar-nav navbar-right panel-group"><li id="menu-item-113003" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-113003 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse1" data-redirect-url="http://littlevillagemag.com/latest/" data-default-url="#collapse1" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse">The Latest</a><a href="#collapse1" class="dropdown-toggle collapsed megamenu-right-icon" data-hover="dropdown" data-toggle="collapse"><i class="fa fa-angle-down megamenu-mobile-icon"></i></a>
<ul id="collapse1" class="dropdown-menu mega-menu panel-collapse collapse">
	<li id="menu-item-113005" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-113005 dropdown-toggle collapsed"><a href="http://littlevillagemag.com/category/community-and-news/">Community/News</a></li>
	<li id="menu-item-113004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113004 dropdown-toggle collapsed"><a href="http://littlevillagemag.com/category/arts-and-entertainment/">Arts &#038; Entertainment</a></li>
	<li id="menu-item-113006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113006 dropdown-toggle collapsed"><a href="http://littlevillagemag.com/category/food-and-drink/">Food &#038; Drink</a></li>
	<li id="menu-item-113007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113007 dropdown-toggle collapsed"><a href="http://littlevillagemag.com/category/columns/albumreviews/">Album Reviews</a></li>
</ul>
</li>
<li id="menu-item-113008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113008 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse2" data-redirect-url="http://littlevillagemag.com/calendar/" data-default-url="#collapse2" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse">Events</a></li>
<li id="menu-item-113012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113012 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse2" data-redirect-url="http://littlevillagemag.com/dining/" data-default-url="#collapse2" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse">Dining</a></li>
<li id="menu-item-113013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113013 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse2" data-redirect-url="http://littlevillagemag.com/about-little-village/" data-default-url="#collapse2" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse">About</a></li>
<li id="menu-item-113009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113009 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse2" data-redirect-url="http://littlevillagemag.com/perks/" data-default-url="#collapse2" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse">Shop</a></li>
<li id="menu-item-113062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113062 menu-first-level simple-dropdown-right dropdown panel simple-dropdown dropdown-toggle collapsed"><a href="#collapse2" data-redirect-url="http://littlevillagemag.com/cart/" data-default-url="#collapse2" class="dropdown-toggle collapsed " data-hover="dropdown" data-toggle="collapse"><i class="fa fa-shopping-cart"></i></a></li>
</ul></div>                </div>
                <!-- end main menu -->
            </div>
        </div>
    </nav>
    </header>

            <section class="no-padding-bottom post-118309 post type-post status-publish format-standard has-post-thumbnail hentry category-community-and-news tag-activism tag-city-council tag-county-supervisors tag-political-party tag-politics-blog">
                <div class="container col2-layout">
                    <div class="row">
                    <div class="col-md-8 col-sm-8 col-xs-12"><section  class="no-padding next-prev-post-wrapper">
    <div class="container">
        <div class="row">
            <div class="col-md-12 col-sm-12 col-xs-12 no-padding">
                <h2 class="blog-details-headline text-black">This week in political activism: June 5 &#8211; 11</h2>
                <div class="blog-date no-padding-top">Posted by  <a class="url fn n" href="http://littlevillagemag.com/author/eleanore-taft/">Eleanore Taft</a> | Jun 5, 2017 | <a class="white-text" href="http://littlevillagemag.com/category/community-and-news/" rel="category tag">Community/News</a></div>
                <div class="margin-tb-30px">
                <div class="blog-image bg-transparent"><img width="760" height="511" src="http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg" class="attachment-full size-full wp-post-image" alt="" title="" srcset="http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg 760w, http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride-410x276.jpg 410w, http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride-640x430.jpg 640w" sizes="(max-width: 760px) 100vw, 760px" /></div>                </div>



<div class="top-social">
 			<div class="text-center padding-four-top padding-four-bottom col-md-12 col-sm-12 col-xs-12 no-padding-lr">
				            <a class="btn social-icon social-icon-large button" href="http://www.facebook.com/sharer.php?u=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-facebook"></i></a>
							            <a class="btn social-icon social-icon-large button" href="https://twitter.com/share?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-twitter"></i></a>
							            <a class="btn social-icon social-icon-large button" href="//plus.google.com/share?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" target="_blank" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-google-plus"></i></a>
										<a class="btn social-icon social-icon-large button" href="http://linkedin.com/shareArticle?mini=true&amp;url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/&amp;title=This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011" target="_blank" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-linkedin"></i></a>
							            <a class="btn social-icon social-icon-large button" href="//pinterest.com/pin/create/button/?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/&amp;media=http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg&amp;description=This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-pinterest"></i></a>
																			    </div>
	    	<div style="clear:both;"></div>
</div>

                <div class="blog-details-text">
                    <h3 style="margin-bottom: 30px;">Ready to take action to build the community, state and nation you want, but not sure what to do next? Here are some opportunities for political activism this week.</h3>
<div id="attachment_118449" style="width: 770px" class="wp-caption alignnone"><img src="http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg" alt="" width="760" height="511" class="size-full wp-image-118449" srcset="http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg 760w, http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride-410x276.jpg 410w, http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride-640x430.jpg 640w" sizes="(max-width: 760px) 100vw, 760px" /><p class="wp-caption-text">Roadside signs along the route of Joni Ernst&#8217;s Roast and Ride next to signs from Planned Parenthood of the Heartland. &#8212; photo by Chris Laursen</p></div>
<h4>Have a drink and network</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/440888692912266/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">Drinking Liberally Iowa City</a></h3>
<p><em>Devotay (117 N Linn St, Iowa City) &#8212; Tuesday, June 6 at 5 p.m.</em>
</div>
<p>Have a couple beers with local movers and shakers in the political scene and discuss local candidates, the upcoming school bond vote and the whirlwind of federal activity.</p>
<h4>Hear from one side of the school bond debate</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/420364104999829/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">Pass the Bond: Information &#038; Activism Tour &#8211; Iowa City</a></h3>
<p><em>Big Grove Brewery &#038; Taproom (1225 S Gilbert St, Iowa City) &#8212; Tuesday, June 6 at 5 p.m.</em>
</div>
<p>This fall, Iowa City Community School District voters will weigh in on whether to pass the largest general obligation bond in state history. Supporters of the bond will make their case and share information at this public event.</p>
<h4>Connect with a major statewide organization</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="http://iowacci.org/calendar/?event_id=429" target="_blank">Doing Politics Differently</a></h3>
<p><em>Mercer Park Aquatic Center (2701 Bradford Dr, Iowa City) &#8212; Tuesday, June 6 at 6:30 p.m.</em>
</div>
<p>Talk with Iowa Citizens for Community Improvement about the problems with business-as-usual politics and what we can do to move forward in a different direction with electoral strategy and a variety of upcoming events.</p>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/419224145110147/?acontext=%7B%22source%22%3A4%2C%22action_history%22%3A%22null%22%7D&#038;source=4&#038;action_history=null" target="_blank">Linn County Iowans for Public Education meeting</a></h3>
<p><em>Hiawatha Public Library (150 W Willman St) &#8212; Wednesday, June 7 at 5:30 p.m.</em>
</div>
<p>Iowans for Public Education is a nonpartisan, grassroots organization that works to educate Iowans about issues impacting public education and defend against legislation that could negatively impact public education. This is the second meeting of the Linn County group and attendees will get a crash course in community organizing and strategic issue campaigns. All are welcome.</p>
<h4>Stand with low-wage workers and immigrants</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/254254921715581/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">Center for Worker Justice Allies Meeting</a></h3>
<p><em>Center for Worker Justice of Eastern Iowa (940 S Gilbert Ct) &#8212; Friday, June 9 at noon</em>
</div>
<p>Those who are financially comfortable and legally documented to live in the United States can still  support others in the struggle for affordable housing, immigrants&#8217; rights and a living wage at these bi-monthly meetings.</p>
<div id="attachment_117954" style="width: 770px" class="wp-caption alignnone"><img src="http://littlevillagemag.com/wp-content/uploads/2017/05/Water-protectors-after-release-1.jpg" alt="" width="760" height="510" class="size-full wp-image-117954" srcset="http://littlevillagemag.com/wp-content/uploads/2017/05/Water-protectors-after-release-1.jpg 760w, http://littlevillagemag.com/wp-content/uploads/2017/05/Water-protectors-after-release-1-410x275.jpg 410w, http://littlevillagemag.com/wp-content/uploads/2017/05/Water-protectors-after-release-1-640x429.jpg 640w" sizes="(max-width: 760px) 100vw, 760px" /><p class="wp-caption-text">Aaron Silander (in red), Mary Beth Versgrove (in green) and Miriam Kashia (kneeling in blue) outside the Lee County sheriff&#8217;s office after being released from jail for protesting the Dakota Access Pipeline Oct 2, 2016. &#8212; photo by Cheryl Valenta</p></div>
<h4>Join the fight against climate change</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/1410559832323034/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">June meeting of Iowa City Climate Advocates</a></h3>
<p><em>Iowa City Public Library &#8212; Saturday, June 10 at 11 a.m.</em>
</div>
<p>Join a national live video conference with Citizens&#8217; Climate Lobby and find out what you can do locally and nationally to advocate for responsible environmental policy.</p>
<h4>Catch some tunes for a cause</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/1279703458764716/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">John Rapson performs Hot Tamale Louie: Benefit for IC Compassion</a></h3>
<p><em>The Mill (120 E Burlington St, Iowa City) &#8212; Friday, June 9 at 7 p.m.</em>
</div>
<p>Local musicians perform <em>Hot Tamale Louie</em>, an original performance inspired by the story of Afghan immigrant Zarif Khan who ran a tamale business in Sheridan, Wyoming and became a local icon. Proceeds for the benefit will go to IC Compassion, an organization that provides information and assistance to refugee and immigrant Iowans.</p>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/426406191057583/?active_tab=about" target="_blank">The Quire presents Make Them Hear You: Songs of Pride &#038; Protest</a></h3>
<p><em>Zion Lutheran Church (310 N Johnson St) &#8212; Saturday, June 10 at 7:30 p.m.</em>
</div>
<p>Eastern Iowa&#8217;s GLBT chorus&#8217; spring concert reminds us to bring more music to this revolution with Songs of Pride and Protest.</p>
<h4>What&#8217;s even better than brunch? Brunch for social justice</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/385901701805973/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">Social Justice League brunch</a></h3>
<p><em>Environmental Education Center (2401 Scott Blvd SE, Iowa City) &#8212; Sunday, June 11 at 11 a.m.</em>
</div>
<p>Connect with local organizers and join a conversation about maintaining self-care while changing the world, led by University of Iowa Diversity Resources Coordinator Kendra Malone. Bring a dish to share and information about social justice-related actions the group may want to participate in.</p>
<h4>Get involved with a political party</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="https://calendar.google.com/calendar/render?eid=bGEyOWxiOWg3am9pOWRtM282bThmNWFiY29fMjAxNzA2MDVUMjMwMDAwWiA1b2lqZW0zbWloazAyOWJib29oZDlzMmg1b0Bn&#038;ctz=America/Chicago&#038;sf=true&#038;output=xml#eventpage_6" target="_blank">Johnson County Republicans meeting</a></h3>
<p><em>Miller Learning Center (2010 Keokuk St, Iowa City) &#8212; Monday, June 5 at 6 p.m.</em>
</div>
<p>Check in with the Johnson County GOP, have a free meal and find out how you can be a part of the organization.</p>
<div class="eventbox">
<h3 class="eventtag"><a href="https://www.facebook.com/events/1268993939866033/?acontext=%7B%22action_history%22%3A[%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22calendar_tab%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22surface%22%2C%22surface%22%3A%22permalink%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22mechanism%22%3A%22upcoming_events_card%22%2C%22surface%22%3A%22dashboard%22%2C%22extra_data%22%3A%22[]%22%7D%2C%7B%22surface%22%3A%22dashboard%22%2C%22mechanism%22%3A%22calendar_tab%22%2C%22extra_data%22%3A%22[]%22%7D]%2C%22source%22%3A2%7D" target="_blank">Coralville and North Liberty GOTV kickoff party</a></h3>
<p><em>Coralville Public Library &#8212; Saturday, June 10 at 10 a.m.</em>
</div>
<p>Join the Johnson County Democrats at a get-out-the-vote kickoff party to begin organizing for 2018.</p>
<h4>Start local by getting to know your county supervisors and city council</h4>
<div class="eventbox">
<h3 class="eventtag"><a href="http://www8.iowa-city.org/weblink/0/edoc/1583441/06-06-17%20Agenda.pdf" target="_blank">Iowa City Council meeting</a></h3>
<p><em>Iowa City Hall &#8212; Tuesday, June 6 at 7 p.m.</em>
</div>
<div class="eventbox">
<h3 class="eventtag"><a href="http://www.linncounty.org/Calendar.aspx?EID=1153&#038;month=6&#038;year=2017&#038;day=7&#038;calType=0" target="_blank">Linn County Supervisors meeting</a></h3>
<p><em>Jean Oxley Linn County Public Service Center (935 2nd St SW, Cedar Rapids) &#8212; Wednesday, June 7 at 10 a.m.</em>
</div>
<div class="eventbox">
<h3 class="eventtag"><a href="http://johnsoncountyia.iqm2.com/Citizens/Detail_Meeting.aspx?ID=2018" target="_blank">Johnson County Supervisors meeting</a></h3>
<p><em>Johnson County Administration Building (913 S Dubuque St, Iowa City) &#8212; Thursday, June 8 at 5:30 p.m.</em>
</div>
<p>The supervisors will consider a resolution to honor the goals of the Paris climate accord, following President Trump&#8217;s announcement last week that he will withdraw the U.S. from the agreement. Come early, to the Health and Human Services Building next door (855 S Dubuque St) at 4 p.m., to hear from local legislators.</p>
<div class="eventbox">
<h3 class="eventtag"><a href="http://www.cityofmarion.org/about-us/mayor-city-council/next-council-meeting" target="_blank">Marion City Council meeting</a></h3>
<p><em>Marion City Hall &#8212; Thursday, June 8 at 5:30 p.m.</em>
</div>
<p><em>Did we miss something? Feel free to comment below with additional events!</em></p>
                    
<div id="sticky-break"></div>

                                <div class="blog-date no-padding-top margin-eight no-margin-bottom">
                                    <h5 class="widget-title margin-one no-margin-top">Tags</h5> <a href="http://littlevillagemag.com/tag/activism/" rel="tag">Activism</a>, <a href="http://littlevillagemag.com/tag/city-council/" rel="tag">city council</a>, <a href="http://littlevillagemag.com/tag/county-supervisors/" rel="tag">county supervisors</a>, <a href="http://littlevillagemag.com/tag/political-party/" rel="tag">political party</a>, <a href="http://littlevillagemag.com/tag/politics-blog/" rel="tag">Politics</a>                                </div>
                                                                </div>
                                            
                <div class="text-center margin-ten no-margin-bottom about-author text-left bg-gray">
    <div class="blog-comment text-left clearfix no-margin">
                <a class="comment-avtar no-margin-top" href="http://littlevillagemag.com/author/eleanore-taft/">
            <img alt='' src='http://0.gravatar.com/avatar/09e24b2cc40a215cb8401fc688dc9ffe?s=300&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/09e24b2cc40a215cb8401fc688dc9ffe?s=600&amp;d=identicon&amp;r=g 2x' class='avatar avatar-300 photo' height='300' width='300' />        </a>
                        <div class="comment-text overflow-hidden position-relative">
            <h5 class="widget-title">About The Author</h5>
            <p class="blog-date no-padding-top"><a href="http://littlevillagemag.com/author/eleanore-taft/">Eleanore Taft</a></p>
            <p class="about-author-text no-margin">Eleanore Taft is <em>Little Village</em>'s production manager. Contact her at <a href="mailto:eleanore@littlevillagemag.com">eleanore@littlevillagemag.com</a>.</p>
        </div>
            </div>
</div>

<h3 class="share-this">Share this article</h3>     

                		<div class="text-center padding-four-top padding-four-bottom col-md-12 col-sm-12 col-xs-12 no-padding-lr">
				            <a class="btn social-icon social-icon-large button" href="http://www.facebook.com/sharer.php?u=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-facebook"></i></a>
							            <a class="btn social-icon social-icon-large button" href="https://twitter.com/share?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-twitter"></i></a>
							            <a class="btn social-icon social-icon-large button" href="//plus.google.com/share?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/" target="_blank" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-google-plus"></i></a>
										<a class="btn social-icon social-icon-large button" href="http://linkedin.com/shareArticle?mini=true&amp;url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/&amp;title=This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011" target="_blank" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-linkedin"></i></a>
							            <a class="btn social-icon social-icon-large button" href="//pinterest.com/pin/create/button/?url=http://littlevillagemag.com/this-week-in-political-activism-june-5-11/&amp;media=http://littlevillagemag.com/wp-content/uploads/2017/06/roastnride.jpg&amp;description=This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011" onclick="window.open(this.href,this.title,'width=500,height=500,top=300px,left=300px');  return false;"  rel="nofollow" target="_blank" title="This%20week%20in%20political%20activism%3A%20June%205%20%26%238211%3B%2011"><i class="fa fa-pinterest"></i></a>
																			    </div>
	                               

<div style="clear:both;"></div>

<div class="single-post-module">
	<h3 class="perk-module-title module-title">BUY HALF-PRICE GIFT CARDS</h3>

	<p class="perk-module-text module-text"><a href="http://littlevillagemag.com/perks/" target="_blank">Generously offered by businesses in the Iowa City area</a></p>

	<a href="http://littlevillagemag.com/perks/" target="_blank"><img class="perk-module-img" src="http://littlevillagemag.com/wp-content/uploads/2015/08/Baroncini_600x500.jpg"></a>
	
	<a href="http://littlevillagemag.com/perks/" target="_blank"><img class="perk-module-img" src="http://littlevillagemag.com/wp-content/uploads/2017/04/Brewlab_FB.jpg"></a>

	<a href="http://littlevillagemag.com/perks/" target="_blank"><img class="perk-module-img" src="http://littlevillagemag.com/wp-content/uploads/2015/08/sushi-600.jpg"></a>
</div>                                       
       
<div style="clear:both;"></div>



<div style="clear:both;"></div>                                     
                <div id="comments" class="comments-area border-top  padding-ten-top">
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Add a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/this-week-in-political-activism-june-5-11/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="http://littlevillagemag.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input id="author" name="author" type="text" onfocus="return inputfocus(this.id);" placeholder="NAME *" value="" size="30" />
<input id="email" name="email" type="text" onfocus="return inputfocus(this.id);" placeholder="EMAIL *" value="" size="30" required/>
<input id="url" name="url" type="text" placeholder="WEBSITE" value="" size="30" />
<textarea id="comment" name="comment" onfocus="return inputfocus(this.id);" placeholder="COMMENT *" aria-required="true"></textarea><span class="required">*Please complete all fields correctly</span><p class="form-submit"><input name="submit" type="submit" id="submit" class="highlight-button-dark btn btn-small no-margin-bottom submit comment-button" value="send message" /> <input type='hidden' name='comment_post_ID' value='118309' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c4d87ec4cd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="225"/></p>			</form>
			</div><!-- #respond -->
	
</div>
            </div>
        </div>
    </div>
</section></div><div class="col-md-3 col-sm-4 col-xs-12 col-md-offset-1 xs-margin-top-seven sidebar pull-right"><!-- fixed widget --><!-- sidebar --><div id="text-43" class="widget widget_text"><!-- heading --><h5 class="widget-title font-alt">Little Village is supported by:</h5><div class="thin-separator-line bg-dark-gray no-margin-lr"></div><!-- end heading -->			<div class="textwidget"><div class="sidebar-ad"><!-- /16322013/300x250_1 -->
<div id='div-gpt-ad-1488236908701-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1488236908701-0'); });
</script>
</div>
<p style="font-size: 10px; margin: 0; padding-top: 3px; padding-bottom: 7px;">Advertisement</p>
</div>
<div class="sidebar-ad"><!-- /16322013/300x250_2 -->
<div id='div-gpt-ad-1488236908701-1' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1488236908701-1'); });
</script>
</div>
<p style="font-size: 10px; margin: 0; padding-top: 3px; padding-bottom: 7px;">Advertisement</p>
</div>
<div class="sidebar-ad"><!-- /16322013/300x250_3 -->
<div id='div-gpt-ad-1488236908701-2' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1488236908701-2'); });
</script>
</div>
<p style="font-size: 10px; margin: 0; padding-top: 3px; padding-bottom: 7px;">Advertisement</p>
</div></div>
		</div><!-- end sidebar --></div>


<div style="clear:both;"></div>
<div style="display:none; width:100%; height:1px; background-color:#ccc;">



</div>



<section class="no-padding clear-both"><div class="container"><div class="row"><div class="wpb_column vc_column_container col-md-12 no-padding"><div class="hcode-divider border-top xs-no-padding-bottom xs-padding-five-top margin-five-top padding-five-bottom"></div></div><div class="col-md-12 col-sm-12 center-col text-center margin-eight no-margin-top xs-padding-ten-top"><h3 class="blog-single-full-width-h3">Related Articles from Little Village</h3></div><div class="blog-grid-listing padding-ten-bottom col-md-12 col-sm-12 col-xs-12 no-padding"><div class="col-md-4 col-sm-4 col-xs-12 blog-listing no-margin-bottom xs-margin-bottom-ten wow fadeInUp animated" data-wow-duration="300ms" style="visibility: visible; animation-duration: 300ms; animation-name: fadeInUp;"><div class="blog-image"><a href="http://littlevillagemag.com/complaint-resolved-against-iowa-citys-rev-anna-blaedel-for-performing-same-sex-wedding/"><img width="374" height="234" src="http://littlevillagemag.com/wp-content/uploads/2017/06/wesley-374x234.jpg" class="attachment-hcode-related-post size-hcode-related-post wp-post-image" alt="" title="" srcset="http://littlevillagemag.com/wp-content/uploads/2017/06/wesley-374x234.jpg 374w, http://littlevillagemag.com/wp-content/uploads/2017/06/wesley-133x83.jpg 133w" sizes="(max-width: 374px) 100vw, 374px" /></a></div><div class="blog-details no-padding"><div class="blog-date">Posted by eleanore-taft</div><div class="blog-title"><a href="http://littlevillagemag.com/complaint-resolved-against-iowa-citys-rev-anna-blaedel-for-performing-same-sex-wedding/">Complaint resolved against Iowa City&#8217;s Rev. Anna Blaedel for performing same-sex wedding</a></div><div class="blog-short-description">The United Methodist Church and Rev. Anna Blaedel, Executive Director and Campus Minister at the Wesley Center, have come to a &#8220;just resolution&#8221; of a complaint the church filed against...</div><div class="separator-line bg-black no-margin-lr"></div></div><div></div></div><div class="col-md-4 col-sm-4 col-xs-12 blog-listing no-margin-bottom xs-margin-bottom-ten wow fadeInUp animated" data-wow-duration="600ms" style="visibility: visible; animation-duration: 300ms; animation-name: fadeInUp;"><div class="blog-image"><a href="http://littlevillagemag.com/kim-weaver-cites-personal-safety-concerns-as-she-drops-bid-against-steve-king/"><img width="312" height="234" src="http://littlevillagemag.com/wp-content/uploads/2017/01/protestsignnearwomensmarch_captial-e1489442265993.jpg" class="attachment-hcode-related-post size-hcode-related-post wp-post-image" alt="" title="" /></a></div><div class="blog-details no-padding"><div class="blog-date">Posted by lauren-shotwell</div><div class="blog-title"><a href="http://littlevillagemag.com/kim-weaver-cites-personal-safety-concerns-as-she-drops-bid-against-steve-king/">Kim Weaver cites personal safety concerns as she drops bid against Steve King</a></div><div class="blog-short-description">Kim Weaver (D) announced over the weekend that she would be dropping her candidacy for the U.S. House race in Iowa's fourth congressional district, a race which pitted her against...</div><div class="separator-line bg-black no-margin-lr"></div></div><div></div></div><div class="col-md-4 col-sm-4 col-xs-12 blog-listing no-margin-bottom xs-margin-bottom-ten wow fadeInUp animated" data-wow-duration="900ms" style="visibility: visible; animation-duration: 300ms; animation-name: fadeInUp;"><div class="blog-image"><a href="http://littlevillagemag.com/new-flower-store-willow-stock-moving-in-to-former-home-ec-workshop/"><img width="374" height="234" src="http://littlevillagemag.com/wp-content/uploads/2017/06/ws_owners-374x234.jpg" class="attachment-hcode-related-post size-hcode-related-post wp-post-image" alt="" title="" srcset="http://littlevillagemag.com/wp-content/uploads/2017/06/ws_owners-374x234.jpg 374w, http://littlevillagemag.com/wp-content/uploads/2017/06/ws_owners-133x83.jpg 133w" sizes="(max-width: 374px) 100vw, 374px" /></a></div><div class="blog-details no-padding"><div class="blog-date">Posted by little-village</div><div class="blog-title"><a href="http://littlevillagemag.com/new-flower-store-willow-stock-moving-in-to-former-home-ec-workshop/">New flower store, Willow &#038; Stock, moving in to former Home Ec. Workshop</a></div><div class="blog-short-description">Amber Neville and Angela Barnett got the keys today to 207 N. Linn Street, the site their future flower shop, Willow & Stock, coming soon to Iowa City's Northside Marketplace.</div><div class="separator-line bg-black no-margin-lr"></div></div><div></div></div></div></div></div></section>                    </div>
                </div>
            </section>
        <div id="sticky-break"></div>
<footer class="bg-light-gray2">
	<div class=" bg-white footer-top"><div class="container"><div class="row margin-four"><div class="col-md-4 col-sm-4 text-center"><i class="icon-phone small-icon black-text"></i><h6 class="black-text margin-two no-margin-bottom">(319) 855-1474 </h6></div><div class="col-md-4 col-sm-4 text-center"><i class="icon-map-pin small-icon black-text"></i><h6 class="black-text margin-two no-margin-bottom">623 S Dubuque Street, Iowa City, IA 52240</h6></div><div class="col-md-4 col-sm-4 text-center"><i class="icon-envelope small-icon black-text"></i><h6 class="margin-two no-margin-bottom"><a href="mailto:editor@littlevillagemag.com">editor@littlevillagemag.com</a></h6></div></div></div></div>	    <div class="container">                        <div class="row margin-four ">
            	                <div class="col-md-6 col-sm-12 sm-text-center sm-margin-bottom-four">
                    <!-- link -->
                    <ul id="menu-lv5-footer-final" class="list-inline footer-link text-uppercase"><li id="menu-item-113017" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-113017"><a href="http://littlevillagemag.com/latest/">The Latest</a></li>
<li id="menu-item-113018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113018"><a href="http://littlevillagemag.com/calendar/">Events</a></li>
<li id="menu-item-113019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113019"><a href="http://littlevillagemag.com/category/food-and-drink/">Dining</a></li>
<li id="menu-item-113020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113020"><a href="http://littlevillagemag.com/about-little-village/">About</a></li>
<li id="menu-item-113021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113021"><a href="http://littlevillagemag.com/perks/">Shop</a></li>
<li id="menu-item-113022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113022"><a href="http://#"><i class="fa fa-shopping-cart"></i></a></li>
</ul>                    <!-- end link -->
                </div>
            	                                    <div class="col-md-6 col-sm-12 footer-social text-right sm-text-center">
                        <!-- social media link -->
                        <!-- sidebar --><div id="text-45" class="widget_text">			<div class="textwidget"><a href="https://www.facebook.com/littlevillagemag" target="_blank">
<i class="fa  fa-facebook"></i>
</a>

<a href="https://twitter.com/LittleVillage" target="_blank">
<i class="fa  fa-twitter"></i>
</a>

<a href="https://plus.google.com/110918578631491948008" target="_blank">
<i class="fa  fa-google-plus"></i>
</a>

<a href="https://www.instagram.com/littlevillagemag/" target="_blank">
<i class="fa  fa-instagram"></i>
</a></div>
		</div><!-- end sidebar -->                        <!-- end social media link -->
                        
                    </div>
                            </div>
            </div>    <div class="container-fluid bg-dark-gray footer-bottom">
        <div class="container">
            <div class="row margin-three">
                                    <!-- copyright -->
                    <div class="col-md-12 col-sm-12 col-xs-12 copyright text-left letter-spacing-1 xs-text-center xs-margin-bottom-one light-gray-text2">
                        <span style="color:#222;">© 2017 Little Village</span> | Website by <a class="footer-credit" href="http://www.littlevillagecreative.com" target="_blank">LV Creative Services</a></span>                    </div>
                    <!-- end copyright -->
                                            </div>
        </div>
    </div>
<!-- scroll to top -->
    <a class="scrollToTop" href="javascript:void(0);">
        <i class="fa fa-angle-up"></i>
    </a>
<!-- scroll to top End... -->
</footer>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='//littlevillagemag.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/this-week-in-political-activism-june-5-11\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//littlevillagemag.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript' src='//littlevillagemag.com/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/this-week-in-political-activism-june-5-11\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//littlevillagemag.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/modernizr.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/bootstrap.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/bootstrap-hover-dropdown.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.easing.1.3.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/skrollr.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.viewport.mini.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/smooth-scroll.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/wow.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/page-scroll.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.easypiechart.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.parallax-1.1.3.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.isotope.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.magnific-popup.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/popup-gallery.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.appear.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/text-effect.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.tools.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/counter.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.fitvids.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/imagesloaded.pkgd.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/jquery.placeholder.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/one-page-main.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var hcodeajaxurl = {"ajaxurl":"http:\/\/littlevillagemag.com\/wp-admin\/admin-ajax.php","theme_url":"http:\/\/littlevillagemag.com\/wp-content\/themes\/h-code"};
var simpleLikes = {"ajaxurl":"http:\/\/littlevillagemag.com\/wp-admin\/admin-ajax.php","like":"Like","unlike":"Unlike"};
/* ]]> */
</script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/themes/h-code/assets/js/main.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
var q2w3_sidebar_options = new Array();
q2w3_sidebar_options[0] = { "sidebar" : "hcode-page-right-sidebar", "margin_top" : 72, "margin_bottom" : 0, "stop_id" : "sticky-break", "screen_max_width" : 770, "screen_max_height" : 0, "width_inherit" : false, "refresh_interval" : 1500, "window_load_hook" : false, "disable_mo_api" : false, "widgets" : ['text-43'] };
</script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js'></script>
<script type='text/javascript' src='http://littlevillagemag.com/wp-includes/js/wp-embed.min.js'></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=306861662720244";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script></body>
</html>